首页 > java, 网站 > struts2再发现高危漏洞,升级到struts2.3.15

struts2再发现高危漏洞,升级到struts2.3.15

2013年7月18日 亲亲宝宝 发表评论 阅读评论

昨日,互联网遭受了一场漏洞风波——Apache Struts2高危漏洞,影响到Struts 2.0.0 – Struts 2.3.15的所有版本。全球千万网站及国内各大网站均受到不同程度的影响。攻击者可以利用该漏洞执行恶意java代码,最终导致网站数据被窃取、网页被篡改等严重后果。

为此,安全联盟合作伙伴scanv安全中心紧急开发了一款在线小工具,可以帮您快速诊断是否存在此漏洞,详情点击:http://www.scanv.com/tools/ ,此诊断工具真够意思,我更新了新版本的,只是struts的文件名还是老的,就提示“您的网站存在Struts 2.3.15 命令执行漏洞”,改下名字就提示没有漏洞了,太不靠谱了。如果网站存在此漏洞,请您进行紧急修复,升级至官方最新版本Struts 2.3.15.1,下载地址:http://struts.apache.org/download.cgi#struts23151

 

struts-2.3.12升级到struts-2.3.15.1需要更新的文件有两个struts2-core-2.3.15.1.jar和xwork-core-2.3.15.1.jar

详情页面:http://struts.apache.org/release/2.3.x/docs/s2-016.html

分类: java, 网站 标签: 11,947 次阅读
原文链接:http://www.wenhq.com/article/view_779.html
欢迎转载,请注明出处:亲亲宝宝
  1. 本文目前尚无任何评论.
  1. 本文目前尚无任何 trackbacks 和 pingbacks.